VIN Scan Single VIN Searches not completing

Resolved

This incident has been resolved.
Posted May 26, 2026 - 05:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2026 - 05:46 UTC

Update

Severity 1 - We continue investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 26, 2026 - 03:28 UTC

Update

Severity 1 - We continue investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 26, 2026 - 02:24 UTC

Update

Severity 1 - We continue investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 26, 2026 - 01:33 UTC

Update

Severity 1 - We continue investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 26, 2026 - 00:42 UTC

Update

Severity 1 - We continue investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 25, 2026 - 23:26 UTC

Update

Severity 1 - We continue investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 25, 2026 - 22:19 UTC

Update

Severity 1 - We are currently investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 25, 2026 - 20:23 UTC

Update

Severity 1 - We are currently investigating the issue. VIN Scan website is available but Single VIN searches are pending indefinitely.
Posted May 25, 2026 - 19:12 UTC

Investigating

Severity 1 - We are currently investigating the issue. VIN Scan website is available but Single VIN search is responding very slowly.
Posted May 25, 2026 - 17:12 UTC
This incident affected: VIN Scan (Single VIN Search).